Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
Visit our sponsors:
 Alternative Autos  Become a sponsor!
Alfa156.net site | Want to sponsor?
Technical (156)
 Alfa Romeo forum : Technical (156)
Subject Topic: Engine Rattling Noise Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
MadMarkA
Junior Alfisti
Junior Alfisti
Avatar

Joined: 26†May†2009
Location: United Kingdom
Online Status: Offline
Posts: 2
Posted: 26†May†2009 at 21:03 | IP Logged Quote MadMarkA

Hi,

I have a 156 1.6 (Veloce Sports Pack 2) on a 51 plate with 104k miles on the clock.

It all of a sudden mid journey stated making a horrible "rattling" noise from the rear LHS of the engine (when looking at it). When stationary it idles perfectly, however on acceleration when moving it then suddenly looses power around the 3k rpm mark and then power comes and goes spuriously with this noise. When revving the engine when stationary this rattle seems to be as the engine decelerates. I can only describe it as though someone has put some ball bearings in the engine......

A local garage has told me they think it is a MAF problem (quoting me £600 fitted). I'm sure it isn't this as I removed the MAF tonight (thanks to Jeff's guide) and there was no difference at all.

They have also suggested it is a CAT problem and that this will cost me a further £1k fitted.

Please help as I love this car and am stuck for ideas (and indeed if the prices I am being quoted are a rip off).

Thanks for reading this.
Mark
Back to Top View MadMarkA's Profile Search for other posts by MadMarkA
 
156-2.5-V6
Senior Alfisti
Senior Alfisti
Avatar
Best Newcomer 07, Best Spammer 08

Joined: 28†September†2007
Location: Sao Tome and Principe
Online Status: Offline
Posts: 16683
Posted: 26†May†2009 at 22:01 | IP Logged Quote 156-2.5-V6

Err - walk away from a place that is quoting you those stoopid figures & take it to an Alfa specialist

__________________
Back to Top View 156-2.5-V6's Profile Search for other posts by 156-2.5-V6
 
natalie135
Junior Alfisti
Junior Alfisti
Avatar

Joined: 25†May†2009
Online Status: Offline
Posts: 31
Posted: 26†May†2009 at 22:54 | IP Logged Quote natalie135

This sounds exactly the same as the problem i've got with my 1999 2.0 T-spark Selespeed and everybody has said the CAT is probably knackered and it smells of egg sometimes. a grand is ridiculous though, £200 max i would have thought but never heard of a MAF before though, what is it?
Back to Top View natalie135's Profile Search for other posts by natalie135
 
natalie135
Junior Alfisti
Junior Alfisti
Avatar

Joined: 25†May†2009
Online Status: Offline
Posts: 31
Posted: 26†May†2009 at 22:56 | IP Logged Quote natalie135

mine has got 106k by the way so it seems a bit of a coincidence that they've got nearly identical milage, probably just the life of the CAT
Back to Top View natalie135's Profile Search for other posts by natalie135
 
JON156VELOCE
Junior Alfisti
Junior Alfisti
Avatar

Joined: 17†May†2006
Location: United Kingdom
Online Status: Offline
Posts: 1239
Posted: 27†May†2009 at 00:02 | IP Logged Quote JON156VELOCE

Yes stay away from that garage, were they wearing a mask and carrying a gun when they gave you those prices
Maf is about £100 plus about half an hours labour for fitting and a cat is about £200 plus an hours labour

I cant see the maf making a rattle but the cat might.

I hope it is a rattling noise not knocking and your oil warning light isnt on and it does have good oil in it..?
Back to Top View JON156VELOCE's Profile Search for other posts by JON156VELOCE
 
JON156VELOCE
Junior Alfisti
Junior Alfisti
Avatar

Joined: 17†May†2006
Location: United Kingdom
Online Status: Offline
Posts: 1239
Posted: 27†May†2009 at 00:04 | IP Logged Quote JON156VELOCE

natalie135 wrote:
never heard of a MAF before though, what is it?


You not had your Alfa long then...


Mass Airflow Meter, it measures the amount of air going into the engine and is a common part to fail causing flat spots and loss of power

Edited by JON156VELOCE on 27†May†2009 at 00:09
Back to Top View JON156VELOCE's Profile Search for other posts by JON156VELOCE
 
natalie135
Junior Alfisti
Junior Alfisti
Avatar

Joined: 25†May†2009
Online Status: Offline
Posts: 31
Posted: 28†May†2009 at 17:42 | IP Logged Quote natalie135

JON156VELOCE wrote:
natalie135 wrote:
never heard of a MAF before though, what is it?


You not had your Alfa long then...


Mass Airflow Meter, it measures the amount of air going into the engine and is a common part to fail causing flat spots and loss of power


Ahhh!!! handy to know Lol, but the eggy smell???? only had the Alfa a month, heard lots of nasties but cant help but love the car. there is a serious flat spot in mine above 3000 ish rpm for a 150+bhp car that cant beat a KA off the lights!!
Back to Top View natalie135's Profile Search for other posts by natalie135
 
Chris T
Veloce
Veloce
Avatar
R-up Most Etertaining 06, Pin 08

Joined: 25†June†2003
Location: Aruba
Online Status: Offline
Posts: 8814
Posted: 28†May†2009 at 19:37 | IP Logged Quote Chris T

Eggy smell will be the CAT I would imagine. As for the rattling it could be something that's just worked loose and needs tightening. Have a prod around (with the engine off!).

As for the loss of power if it ain't the MAF have a look at a few things like the air filter in case it's completely buggered, plugs, the state of the coil packs incase ones cracked etc.

Try the simple stuff first.

__________________
What can I say about driving; if you're still in control you're not going quick enough.
Back to Top View Chris T's Profile Search for other posts by Chris T
 
MadMarkA
Junior Alfisti
Junior Alfisti
Avatar

Joined: 26†May†2009
Location: United Kingdom
Online Status: Offline
Posts: 2
Posted: 29†May†2009 at 08:38 | IP Logged Quote MadMarkA

Thanks for all of your input so far.

I have tried all the simple stuff for rattles etc but to no avail. Kwik Fit have confirmed that it isn't a Cat issue (they were quoting £590 for 2 x new Cat's and exhaust pipes etc fitted if it was that anyway) so I have now found and taken it to an Alfa specialist.

Encouraging they say they haven't heard a noise like this before and they think it may be something as simple as a belt or tensioner that has slipped/snapped or something and will let me know next week.

I will keep you posted.
Back to Top View MadMarkA's Profile Search for other posts by MadMarkA
 
Betty_Swallocks
Junior Alfisti
Junior Alfisti
Avatar

Joined: 05†September†2010
Location: United Kingdom
Online Status: Offline
Posts: 6
Posted: 11†September†2010 at 14:28 | IP Logged Quote Betty_Swallocks

Did you get a resolution to this?
I have a rattle that sounds very much like yours on my 2.0 147.
It's going down to Royston on Wednesday for a cambelt and associated gubbins and I'm hoping that's going to sort it out.
I'd be interested to hear what the answer to your problem was.
Back to Top View Betty_Swallocks's Profile Search for other posts by Betty_Swallocks
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide

This page was generated in 0,1719 seconds.