Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
Visit our sponsors:
 Alternative Autos  Become a sponsor!
Alfa156.net site | Want to sponsor?
Technical (159/Brera)
 Alfa Romeo forum : Technical (159/Brera)
Subject Topic: injection system failure warning light. Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
jocky68
Junior Alfisti
Junior Alfisti
Avatar

Joined: 04 November 2006
Location: United Kingdom
Online Status: Offline
Posts: 52
Posted: 13 June 2010 at 16:36 | IP Logged Quote jocky68

Just got my alfa 159 yesterday (06 1.9 jtdm 79,000) and love it. Now my dad wanted to test it out and he stalled it a couple of times and now i have this "get engine checked" message when i start her up and the amber injection system failure light coming on. The car is still running fine though, Ideas?

__________________
Back to Top View jocky68's Profile Search for other posts by jocky68 Visit jocky68's Homepage
 
Richard H
Senior Alfisti
Senior Alfisti
Avatar
I got a mention It took 2 yrs & 9k votes

Joined: 25 November 2004
Location: United Kingdom
Online Status: Offline
Posts: 24620
Posted: 15 June 2010 at 06:39 | IP Logged Quote Richard H

I'd stick some injector cleaner in the fuel.

It may have been a while since it ran and could have got a bit bunged up

__________________
I woke up this morning on this side of the dirt and everything's cool: Nile Rogers
Back to Top View Richard H's Profile Search for other posts by Richard H
 
CJ Romeo
Don Corleone
Don Corleone
Avatar
Random Awards 2010, 05, 07, 2nd ,06

Joined: 15 January 2004
Location: Scotland
Online Status: Offline
Posts: 17624
Posted: 15 June 2010 at 09:30 | IP Logged Quote CJ Romeo

The 1.9 needs a good boot to get it going, its quite easy to stall if you are used to the 'usual' diesel torque at tickover that the multijet just doesnt have and in a big lump like the 159....

The warning is probably just generated by the stalling - if you do it often enough, it will generate a fault as it confuses the ECU.

__________________
2008 Alfa Romeo 159 Ti RIP
2012 MB W212 AMG Sport Das Boot
Back to Top View CJ Romeo's Profile Search for other posts by CJ Romeo
 
jocky68
Junior Alfisti
Junior Alfisti
Avatar

Joined: 04 November 2006
Location: United Kingdom
Online Status: Offline
Posts: 52
Posted: 15 June 2010 at 22:53 | IP Logged Quote jocky68

Cheers guys, the fault light has gone out now so all good. Thats her in the sig by the way.

Edited by jocky68 on 15 June 2010 at 23:04


__________________
Back to Top View jocky68's Profile Search for other posts by jocky68 Visit jocky68's Homepage
 
Richard H
Senior Alfisti
Senior Alfisti
Avatar
I got a mention It took 2 yrs & 9k votes

Joined: 25 November 2004
Location: United Kingdom
Online Status: Offline
Posts: 24620
Posted: 18 June 2010 at 18:36 | IP Logged Quote Richard H

Nice 159!

__________________
I woke up this morning on this side of the dirt and everything's cool: Nile Rogers
Back to Top View Richard H's Profile Search for other posts by Richard H
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide

This page was generated in 0,1406 seconds.