Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin

Also visit the www.Alfa156.net main site
Technical (147)
 Alfa Romeo forum : Technical (147)
Subject Topic: 147/156 2ltr TS rough idle misfire Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
Kiwitrev
Junior Alfisti
Junior Alfisti


Joined: 25 December 2017
Location: Australia
Online Status: Offline
Posts: 1
Posted: 25 December 2017 at 23:10 | IP Logged Quote Kiwitrev

If you have a rough idle or misfire vibrating check out my video it can be a coil which sometimes is faulty when cold ok when hot also may show its sparking but not under load , get yourself a spare coil pack and replace one at a time.
Copy and paste the following link to your browser:
https://www.youtube.com/watch?v=o0VHTtLJmYw&t=7s

Edited by Kiwitrev on 25 December 2017 at 23:12
Back to Top View Kiwitrev's Profile Search for other posts by Kiwitrev
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide

This page was generated in 0,2813 seconds.