Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin

Also visit the www.Alfa156.net main site
Technical (156)
 Alfa Romeo forum : Technical (156)
Subject Topic: P1670 error Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
thesnake
Junior Alfisti
Junior Alfisti
Avatar

Joined: 05 June 2018
Location: United Kingdom
Online Status: Offline
Posts: 2
Posted: 05 June 2018 at 22:52 | IP Logged Quote thesnake

I have a 2.0 JTS GT Selespeed and a 156 2.0 JTS. My GT suddenly developed a misfire and limited rev range on the way home 3 days ago. Garage locally identified P1670 as the error code, fuel pressure fault. They can't detect anything beyond that! Any of you chaps got any ideas? Thanks in advance.

__________________
Just luv em!
Back to Top View thesnake's Profile Search for other posts by thesnake
 
drayco
Junior Alfisti
Junior Alfisti


Joined: 03 August 2011
Location: United Kingdom
Online Status: Offline
Posts: 104
Posted: 06 June 2018 at 00:17 | IP Logged Quote drayco

First, do a forum search, there are a number of threads on this topic.

The JTS fuel system comprises a number of components:
in-tank fuel pump; you should be able to hear this prime when you turn the key on;
in-line fuel filter; can sometimes get blocked; check if there is good fuel pressure reaching the high pressure pump;
high pressure pump; driven off the camshaft; normally very reliable; check for good fuel pressure on the output side; note this is very high pressure so a high pressure test gauge is needed;
high pressure regulator and sensor; dumps excessive pressure; the sensor signal interpreted by the ECU is what is setting the P1670, either the pressure measured is out of range or the sensor is not reporting correctly; a scope or graphing multimeter is needed to check the output from the sensor;
fuel rail and injectors; any of these could be blocked or failing.
The reduced rev range is probably the ECU protecting the engine from running too lean.

You could try swapping pump and regulator sensor with your 156, they are the same, see if the fault moves to the other car; you do, of course, risk having both cars not functioning. Alternatively, I've seen plenty of JTS high pressure fuel pumps on ebay.

__________________
55 2.0 JTS GT Selespeed
02 156 2.0 TS Selespeed SportWagon
03 147 1.6 TS 5-Door
P-reg 3.5 V6 Shogun
Back to Top View drayco's Profile Search for other posts by drayco
 
thesnake
Junior Alfisti
Junior Alfisti
Avatar

Joined: 05 June 2018
Location: United Kingdom
Online Status: Offline
Posts: 2
Posted: 10 June 2018 at 20:24 | IP Logged Quote thesnake

Many thanks Drayco.

__________________
Just luv em!
Back to Top View thesnake's Profile Search for other posts by thesnake
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.92
Copyright ©2001-2004 Web Wiz Guide

This page was generated in 0,2500 seconds.